Knowledgebase

Search:     Advanced search

Metacity Crashes When Using Surround SCM Integrations on Ubuntu

Article ID: 766  |  Last updated: 11 Apr, 2016

Problem

The Metacity window manager crashes or causes third-party applications, such as IntelliJ IDEA, WebStorm, and NetBeans, to become unresponsive or crash when using the Surround SCM integration on Ubuntu.

The following error may be displayed in the terminal:

'Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion `GTK_IS_WIDGET (widget)'

Cause

The default Ubuntu theme enables overlay scrollbars, which can cause applications using Qt 4. x and 5.x, such as Surround SCM, to become unresponsive or crash. Refer to Ubuntu bug reports 805303 and 848808 for more information.

Solution

Use the following command to set the LIBOVERLAY_SCROLLBAR environment variable before using third-party applications.

export LIBOVERLAY_SCROLLBAR=0

Article ID: 766  |   Last updated: 11 Apr, 2016
Tags
Ubuntu MetaCity IntelliJ IDEA WebStorm NetBeans

Prev   Next
Cannot Load Library Error is Returned When Configuring the...     Surround SCM Apache Ant Integration