Knowledgebase

Search:     Advanced search

Controls Duplicated in the QA Wizard Pro Application Repository

Article ID: 791  |  Last updated: 26 Jun, 2017

Problem

An existing control is duplicated in the QA Wizard Pro application repository after recording.

Cause

QA Wizard Pro does not uniquely recognize the existing control in the repository based on the search criteria used to locate it.

Solution

Merge the duplicate controls. After merging, make sure to select appropriate search criteria for the control so it is unique in the repository.

You can also use the following options when reviewing and saving repository changes to help reduce adding duplicate controls to the repository.

  • Make sure the 'Smart matching' option is selected in the Repository Changes dialog box after recording. Smart matching lets QA Wizard Pro automatically modify search criteria to differentiate controls.
  • Select the 'Only add used controls to the repository' option in the Repository Changes dialog box to only add controls you interacted with.
Article ID: 791  |   Last updated: 26 Jun, 2017
Tags
application repository duplicate controls

Prev   Next
Capturing Web Page Text with QA Wizard Pro Functions     QA Wizard Pro Server RDBMS Support