Knowledgebase

Search:     Advanced search

QA Wizard Pro System Requirements

Article ID: 774  |  Last updated: 14 Sep, 2017

This article provides the system requirements and supported browsers for the current version of QA Wizard Pro.

These requirements are intended to be used in combination with the hardware requirements for the application you are testing. They do not account for additional applications or processes that may impact QA Wizard Pro's memory and processor usage, or additional hard disk space that may be required for storing scripts, reports, datasheets, and repositories.

Note: See Server System Requirements for requirements and recommendations for running the QA Wizard Pro Server.

Minimum requirements

  • 1.5 GHz CPU
  • 2 GB RAM
  • Microsoft Windows Vista, Server 2008, 7, 8, 8.1, Server 2012, 10

Note: To successfully use QA Wizard Pro, you must be a member of the local Administrator group on the computer it is running on. Without this access, you may not be able to record scripts and may be prompted to enter a serial number each time QA Wizard Pro starts. Contact your system administrator for help.

Local application repository size considerations

The disk space used by the local application repository increases as the number of controls captured for an application version increases. CPU and RAM usage, which is proportional to repository size, increases temporarily when the repository is modified during recording. 

The following chart provides system recommendations to achieve optimal recording performance based on the local repository size.

Repository size CPU RAM
0 - 5 MB 1.5 GHz 2 GB
6 - 25 MB 1.5 GHz 2 GB
26 - 125 MB 1.8 GHz 2 GB
126 - 250 MB 2.4 GHz 2 GB
251 - 500 MB 3.0 GHz 2 GB
> 500 MB 3.2 GHz 2 GB

Supported browsers

Standard scripts

  • Google Chrome 41 and later
  • Microsoft Internet Explorer 6 - 11
  • Mozilla Firefox 3.6 - 54 (Firefox 55 and later not supported because of architectural changes to Firefox)

Load test scripts (recording)

Only 32-bit browsers are supported.

  • Microsoft Internet Explorer 6 - 11
  • Mozilla Firefox 3.6 - 54 (Firefox 55 and later are not supported because of architectural changes to Firefox)

Dashboard

See Dashboard Supported Web Browsers and Servers for browsers the dashboard is compatible with.

Article ID: 774  |   Last updated: 14 Sep, 2017
Tags
system requirements browser support

Prev   Next
QA Wizard Pro     QA Wizard Pro Integration with TestTrack Pro Fails