Knowledgebase

Search:     Advanced search

Archive Error 9028 When Checking In Files to Surround SCM on Windows

Article ID: 723  |  Last updated: 16 Sep, 2015

Problem

The following error is returned when checking in files to Surround SCM on Windows Server 2003 or later.

'Archive error code: -9028'

Cause

NTFS file systems use the 8.3 naming convention to create short names for long file names and paths that contain spaces or more than eight characters. Surround SCM's default Diff3 merge utility does not support spaces in paths. If the 8.3 naming convention is disabled, Diff3 uses the long name for the directory that stores temporary files created when merging during check in. This causes the archive error if the directory path contains spaces.

Solution

Use one of the following solutions to resolve the issue:

Enable 8.3 naming for the file system

  1. In the system registry on the Surround SCM Server computer, change the HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation key value to 0 (all volumes) or 2 (per volume). Refer to the Microsoft NtfsDisable8dot3NameCreation TechNet article for more information.
  2. Reboot the server computer.

Change the default location for Surround SCM temporary files

  1. On the Surround SCM Server computer, start the Surround SCM Registry Utility.
  2. Click Server Options.
  3. Enter an Application temporary files directory path or click the browse button to select a directory. Use a directory path that does not contain spaces.
  4. Click Validate Options to verify the path is correct.
  5. Click OK to save the changes.
  6. Restart the Surround SCM Server.

Use Guiffy for merging files

  1. In Surround SCM, choose Tools > Administration > Server Options. The Server Options dialog box opens.
  2. Select Merge from the Global Server Options category.
  3. Select Enable Guiffy for automatic merges and configure any options. Refer to the Surround SCM help for more information.
  4. Click OK to save the changes.
  5. Restart the Surround SCM Server.
Article ID: 723  |   Last updated: 16 Sep, 2015
Tags
archive error Windows Server

Prev   Next
Saving Workflow Event Times from Surround SCM in TestTrack 2008...     Automatic Client Upgrades Fail from the Surround SCM 2010.1.0...