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Email is not Sent if the STARTTLS 1.0 Protocol is Used

Article ID: 714  |  Last updated: 23 Dec, 2014

Problem

Email is not sent from Surround SCM or TestTrack and the following error is displayed in the mail queue:

‘Sending email via SMTP failed due to a send error. The SMTP host’s reply code to the MAIL command was 550, but it was expected to be 250. The reply text was “5.7.1 Client does not have permissions to send as this sender".’

This occurs if you are using Microsoft Exchange and if STARTTLS 1.0 is selected as the protocol for sending email via SMTP in Surround SCM or TestTrack, even if the connection test is successful.

Cause

The user configured to connect to the email server from Surround SCM or TestTrack is in an authoritative domain in Exchange, which is not configured to allow authenticated users to send email from a different account. When emails are sent by the Surround SCM or TestTrack Server, the From address is set based on the option selected in the Email Notifications category in the Server Options dialog box (Surround SCM) or the Email category in the Project Options dialog box (TestTrack Client).

Solution

Configure Exchange to allow authenticated users to send email as other users. Grant the Accept Authoritative Domain Sender permission to the authenticated users group for the receive connector. Refer to the Exchange documentation for help.

Article ID: 714  |   Last updated: 23 Dec, 2014
Tags
SMTP mail queue send error STARTTLS Exchange

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