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TestTrack Pro Web ISAPI Extensions Not Properly Installed

Article ID: 562  |  Last updated: 24 May, 2017

Note: The following information applies only to TestTrack 2013.0.2 and earlier.

Problem

When you try to log in to TestTrack Pro Web, an error similar to the following is returned:

'The TestTrack Pro Web ISAPI extensions were not properly installed. The CGI program cannot find the TestTrack registry key.'

Cause #1

The TestTrack Pro Web pages and CGI program were not installed on the web server computer.

Solution #1

Run the TestTrack installer on the web server computer and reinstall the TestTrack web components. The installer updates the registry with the TestTrack settings.


Cause #2

The CGI process generated by the web server does not have read access to the registry.

Solution #2

See Incorrect CGI Information on TestTrack Server Computer.


Cause #3

A version 1.x ttcgi.exe exists on the computer that runs TestTrack. The CGI program looks for a TestTrack Pro Web registry key under HKEY_LOCAL_MACHINE\Software\Seapine Software. If this key does not exist, the ISAPI error is displayed.

Solution #3

Reinstall TestTrack and overwrite the web pages and CGI.

Article ID: 562  |   Last updated: 24 May, 2017
Tags
CGI ISAPI

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