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Incorrect Data in TestTrack Distribution Reports Based on Issue Distribution by Version Found

Article ID: 519  |  Last updated: 26 Mar, 2015

Problem

TestTrack distribution reports using the Issues distributed by option and Version Found value do not include all version values or some values are displayed as unknown.

Cause

By default, each reported by record in an issue has a Version field. Values in this field are configured in the Version Values list (Tools > Configure List Values > Version Values), but users can also enter a value in the field. The report only includes values selected in the Version field that are configured in the Version Values list. Other values that users enter or values that are not versions (e.g., <not set>) are also not included in the report.

Note: The information displayed in the Version Found column in the Issues list window will be different in the report if the issue has more than one reported by record. The column only displays the version from the first reported by record added to the issue, but the report includes versions from all reported by records.

Solution

Restrict users from entering text in the Version field and only allow them to select a value configured in the Version Values list.

  1. Choose Tools > Administration > Project Options and then select the Fields category.
  2. Select Users must select a pop-up menu value in version fields.
  3. Click OK to save the changes.

If you want to allow users to enter text in the Version field, the only way to ensure that all versions are included in the report is to add all possible versions to the Version Values list.

Article ID: 519  |   Last updated: 26 Mar, 2015
Tags
version found distribution report

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