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Incorrect CGI Information on the Helix ALM Server Computer

Article ID: 512  |  Last updated: 28 Jun, 2017

Problem

The following error is returned when using a Helix ALM web client:

‘The Helix ALM Server computer must be updated with the correct CGI information.’

Cause

The Helix ALM CGI process generated by the web server does not have read access to the registry. The Helix ALM web component cannot run because it cannot find where the web pages are located, where the Helix ALM Server is running, and the server port number.

Solution

Provide read access to the Helix ALM Server (formerly known as TestTrack Server) registry key on the server computer.

Note: The following steps include editing the registry. Only users familiar with Windows administration should edit the registry.

  1. Locate the following registry key:
    HKEY_LOCAL_MACHINE\Software\Seapine Software\TestTrack\TestTrack Server
  2. Choose Edit > Permissions.
  3. Ensure that Everyone and the anonymous user both have Read permissions for the registry. Permissions are propagated down. If Read permissions are not available at any place in the path, starting with HKEY_LOCAL_MACHINE, all subsequent directories will not have Read permissions.
Article ID: 512  |   Last updated: 28 Jun, 2017
Tags
server CGI registry

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