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DSNs Not Displayed in the Helix ALM or License Server Admin Utility

Article ID: 461  |  Last updated: 02 Jun, 2017

Problem

When configuring the Helix ALM Server or Helix ALM License Server to use a SQL Server database, the Data Source Name field in the server admin utility does not include all the configured DSNs. This occurs when configuring a new connection or converting the server database from 32-bit to 64-bit.

Cause

The 32-bit servers can only use DSNs created using the 32-bit ODBC Administrator. The 64-bit servers can only use DSNs created using the 64-bit ODBC Administrator.

Solution

  1. If you are using the 32-bit server, create a DSN using the 32-bit ODBC Administrator. The default location for the 32-bit ODBC Administrator on 64-bit systems is C:\Windows\SysWoW64\Odbcad32.exe.
    The default location on 32-bit systems is C:\Windows\System32\Odbcad32.exe.

    If you are using the 64-bit server, create a DSN using the 64-bit ODBC Administrator. The default location for the 64-bit ODBC Administrator is C:\Windows\System32\Odbcad32.exe.
  2. Restart the server.
    The DSNs are now displayed in the Data Source Name field.
Article ID: 461  |   Last updated: 02 Jun, 2017
Tags
SQL Server 64-bit DSN ODBC

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folder Helix ALM (formerly TestTrack)

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