Knowledgebase

Search:     Advanced search

Cannot Perform Functions with the Helix ALM SDK

Article ID: 434  |  Last updated: 02 Jun, 2017

Problem

The following error is returned when you perform a request, such as getTestCase, using the Helix ALM SDK:

'You do not have sufficient security clearance to perform this function.'

Cause

A license is not assigned to the SOAP user or there is a problem with the logon request in the SOAP script.

Solution

  1. Make sure the SOAP user can access all areas (issue management, requirements management, and test case manangement) using the Helix ALM Client. If they cannot, make sure a valid license is assigned to the user.
  2. Make sure the SOAP script uses the ProjectLogon request and not the deprecated DatabaseLogon request.
Article ID: 434  |   Last updated: 02 Jun, 2017
Tags
SDK security clearance

Prev   Next
TestTrack 2013.1.1 and Earlier Crashes on Mac OS X 10.9     Shrinking the SQL Server Transaction Log Size