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Helix ALM Before Save Triggers Do Not Run

Article ID: 429  |  Last updated: 27 Apr, 2017

Problem

Triggers based on the 'is created' action, such as Issue is created, with the 'Before save' option selected do not run if the selected filter includes a Number, Folders, or Folder Path restriction.

Cause

Before save triggers run when a request to save a record is received by the Helix ALM Server. Number and folder information is not added to records until after they are successfully saved on the server. The triggers never run because they are processed by the server before number or folder information is added to the record.

Solution

Use a filter with different restrictions for the trigger.

Article ID: 429  |   Last updated: 27 Apr, 2017
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trigger

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