Knowledgebase

Search:     Advanced search

TestTrack Project Upgrades Fail

Article ID: 410  |  Last updated: 17 Nov, 2016

Problem

A TestTrack project cannot be upgraded. The following errors are written to the server log:

‘RDBMS data source cannot be upgraded if in use by multiple TestTrack Servers.’
‘The RDBMS data source is in use by another TestTrack Server.’

The following error may be returned in the TestTrack Server Admin Utility:

‘A project cannot be upgraded because the data source is in use by another TestTrack Server.’

Cause

One or more of the projects to be upgraded is associated with another TestTrack Server. Each project stores the universally unique identifier (UUID) of the TestTrack Server that hosts it, and projects can only be associated with one TestTrack Server at a time.

  • If you are upgrading TestTrack native projects, you must upgrade them one at a time. When starting an upgrade, the server checks the UUID stored in the project against the UUID stored on the server. If the values do not match, the upgrade fails.
  • If you are upgrading RDBMS projects stored in an Oracle, PostgreSQL, or SQL Server database, you must upgrade all projects in the database at the same time. If one or more projects in the database has a UUID for a different server, the upgrade fails for all projects. Do not store projects for multiple TestTrack Servers in the same database because data corruption and upgrade issues can occur.

Solution

Make sure all projects you need to upgrade are only associated with the TestTrack Server you are logged in to.

Native projects

To upgrade a TestTrack native project associated with another server:

  1. In the TestTrack Server Admin Utility, select the project and click Remove to remove it.
  2. Click Add Existing to re-add it and replace the old UUID with the current server’s UUID.
  3. Try the upgrade again.

RDBMS projects

To upgrade an RDBMS project, make sure all projects in the database are added to the current server.

Note: All projects in the database will be upgraded. If projects stored in the database are used on other TestTrack Servers, move those projects to a new database first to prevent data corruption or version compatibility issues. Ask your DBA for help.

  1. In the TestTrack Server Admin Utility connected to the current server, click Add Existing to check for projects in the database.
  2. Select RDBMS as the Project type and select the database Connection.
  3. Select Show projects that are currently in use by other servers. The Database project name list is updated with all projects in the database associated with a different server.
  4. Select a project to add and click OK.
  5. Repeat steps 1-4 for all projects in the database.
  6. Upgrade the project. All other projects in the database are also upgraded.
  7. After the projects are upgraded, select any projects not needed on the current server and click Remove to remove them.
Article ID: 410  |   Last updated: 17 Nov, 2016
Tags
UUID rdbms upgrade cannot upgrade data source

Prev   Next
PostgreSQL Returns a Nonstandard Use of Backslashes Warning     Locking Table (Microsoft Access) ODBC Error