Knowledgebase

Search:     Advanced search

TestTrack Web XML Export Does Not Work From Internet Explorer on Mac

Article ID: 360  |  Last updated: 31 May, 2017

Note: The following information only applies to TestTrack Web 2013.0.2 and earlier.

Problem

Exporting to XML from TestTrack Web in Internet Explorer on Mac does not work correctly.

Cause

Internet Explorer incorrectly determines that the XML file is mislabeled and assumes the data is something else. Instead of exporting the XML, a Save As dialog box opens. This is a known bug in Microsoft Internet Explorer that prevents file downloads.

Solution

  1. If the exported XML file is large, click View Source then click Save As when you receive the error.
  2. You can put the TestTrackData.dtd file in the web server's scripts folder, which is where TTCGI.exe is located. Make sure the directory is readable so the web server can access the .dtd file. When an XML file export  is requested, the file will be parsed and opened by the browser. After it is opened in the browser, you can choose File > Save As to save the XML file.
Article ID: 360  |   Last updated: 31 May, 2017
Tags
Mac OS X Internet Explorer xml export

Prev   Next
Automatically Logging In - TestTrack Pro Web 2013.0.2 and Earlier     TestTrack Web Clients 401.3 Errors