Knowledgebase

Search:     Advanced search

TestTrack SMTP Send Mail Error #501

Article ID: 331  |  Last updated: 31 Dec, 2014

Note: The following information only applies to TestTrack 2013.0.2 and earlier.

This article includes information about two separate but related 501 errors.

Problem

The SMTP server returns a 501 Invalid Command In error.

Cause

The mail server expects to receive an extra set of commands or an alternate set of commands before TestTrack initiates its Send Mail command. The extra command could be Username and Password authentication.

Solution

Depending on your web server configuration, you may be able to bypass this by entering a return email address the mail server can authenticate with.

  1. Start TestTrack.
  2. Log in to the project you want to configure.
  3. If you are using the TestTrack Client, choose Tools > Administration > Project Options.
    If you are using TestTrack Pro Web, click the Configure tab and then click Project Options.
  4. Click the Email category.
  5. Enter a return email address for TestTrack to use when sending notifications.

If the problem is not resolved, you may need to reconfigure your mail server to allow send mail requests from the TestTrack Server IP address. This maintains the SMTP authentication while allowing the TestTrack Server to send mail.

In some cases, a virus scanner might be adding its own wrapper to the message. In this case, extra text is added to the send mail request, the mail server misinterprets the extra text, and returns an error.


Problem

The SMTP server returns the following error:

Syntax error in parameter or arguments: FROM: address not fully specified. Error number=501.

Cause

Some mail servers require that a return address be specified before sending mail.

Solution

Enter a return email address that TestTrack can use when sending mail.

  1. Start TestTrack.
  2. Log in to the project you want to configure.
  3. If you are using the TestTrack Client, choose Tools > Administration > Project Options.
    If you are using TestTrack Pro Web, click the Configure tab and then click Project Options.
  4. Click the Email category.
  5. Enter a return email address for TestTrack to use when sending notifications.
Article ID: 331  |   Last updated: 31 Dec, 2014
Tags
SMTP invalid command 501

Prev   Next
Configuring ODBC Data Sources     Configuring an Exchange Server for Email Tracking