Knowledgebase

Search:     Advanced search

Cannot Log In to Web Clients After Upgrading to Mac OS X 10.10 and Later

Article ID: 297  |  Last updated: 08 Sep, 2015

Problem

Users cannot log in to some Seapine web clients after the computer hosting the TestTrack Server or Seapine License Server is upgraded to Mac OS X 10.10 and later. The following web clients are affected:

  • Seapine License Server Web Admin Utility
  • SoloSubmit
  • TestTrack Web
  • TestTrack Web Server Admin Utility

Cause

Mac OS X 10.10 and later uses Apache 2.4. The mod_cgi module is not enabled by default in this Apache version.

Solution

Modify the Apache configuration file (httpd.conf) to enable the mod_cgi module.

  1. In Terminal, enter the following command to back up the current Apache configuration:
    sudo cp /etc/apache2/httpd.conf /etc/apache2/httpd.conf.backup
  2. In Finder, click Go > Go to Folder.
  3. Enter /etc/apache2 and click Go.
  4. Drag the httpd.conf file to the desktop.
  5. Right-click the http.conf file and choose Open With > Other.
  6. Select /Applications/TextEdit and click Open.
  7. Delete # from the following line to uncomment it:
    #LoadModule cgi_module libexec/apache2/mod_cgi.so
  8. Save the file.
  9. Drag the modified httpd.conf file back to the /etc/apache2 folder. You are prompted to authenticate.
  10. Click Authenticate.
  11. Click Replace and enter your password.
  12. Enter the following commands in Terminal to fix ownership and permissions for the httpd.conf file:
    sudo chown root:wheel /etc/apache2/httpd.conf
    sudo chmod 644 /etc/apache2/httpd.conf
  13. Enter the following command to restart the Apache web server:
    sudo apachectl restart
  14. Log in to the Seapine web clients.
Article ID: 297  |   Last updated: 08 Sep, 2015
Tags
web Mac OS X Apache upgrade login CGI

Prev   Next
CGIs on Linux Cannot Connect to the Seapine License Server or...     Cannot Install or Run Seapine Applications on Mac OS X 10.11 (El...