Note: The following information only applies to TestTrack 2011.1.3 and earlier.
Problem
When accessing a table in a Microsoft Access database that is linked to a TestTrack project on a networked computer the following error is returned:
ODBC--Call Failed.
[SYWARE, Inc.][CODEBASE ODBC Driver][Code(#4)
Cause
The DSN (ODBC Data Source) and DBQ (path name to database) are not the same as the networked ODBC Data Source. When Access links to tables, it stores the ODBC Data Source and the path to the database with the table. The ODBC Data Source on the computer accessing the Access database needs to be named and mapped the same as the ODBC Data Source on the networked computer.
Solution
Make sure the Seapine ODBC drivers are named and mapped the same on each computer.
Example
The TestTrack project is stored on Computer A. The folder for the project has proper shares out.
Computer B has a mapped drive to the project on Computer A (e.g., H:\TTDbs). The Seapine ODBC driver is configured using the mapped drive (e.g., the data source is named 'TestTrack ODBC Driver' and is mapped to 'H:\TTDbs\Sample Project'). Computer B stores an Access database linked to the project on Computer A using the Seapine ODBC driver.
Computer C tries to access the Access database stored on Computer B. An error occurs when opening a table in Datasheet view.
To resolve this error, install the Seapine ODBC driver on Computer C. Configure the driver exactly the same as the Seapine ODBC driver installed on Computer B.
The ODBC Data Source on Computer B is named 'TestTrack ODBC Data Source'. Make sure the ODBC Data Source on Computer C is also named 'TestTrack ODBC Data Source'. The ODBC drivers need to be mapped to the same network drive. For example, the ODBC driver on Computer B is mapped to 'H:\TTDbs\Sample Project'. Make sure the ODBC driver on Computer C is mapped to the same network drive.