0 votes
Hi.

We are trying to upgrade our Seapine Server to Server 2016. We simply copied the appropriate files over to the new Test server as documentation suggests and imported postgres database. Although this Test server contained the data needed, it wasn't actually entirely functional, or in production by any stretch. There were still some issues to work out. After restarting the production Seapine server it is now showing all licenses are in a disabled state with no clear way of making them active again.

On the production Seapine server License server it clearly states: If a serial number is found on another license server it is disabled. Delete the serial number from the other server then shut down and restart this license server to fresh the list.

I did this already. I removed all licenses from Test server, then deleted the LicenseServDB file altogether, then uninstalled License Server, and even shut down the machine.

The production Seapine server is still complaining saying the licenses are disabled.  

Documentation doesn't say anything about this that I can find. What else is there to try?
asked Sep 17, 2017 in License Server by itadmin

2 Answers

0 votes
Did you restart the production License Server? Once the serial numbers are flagged as being "in use" the License Server will not reattempt the "in use" check to see if they were freed up, so if you restart the production License Server it will again run the "in use" test.
answered Sep 18, 2017 by RichC (5,990 points)
0 votes
Hi,

yes. This has been resolved with Support's help

The culprit was a very old version of the production machine I was running on my localhost in Hyper-V after doing a P2V conversion. It was ultimately unusable and abandoned, but I had left it running by accident after grabbing some files. License server was also running on it. This is what the production copy of License server was complaining about. I completely forgot about this so naturally I was baffled that this was still a problem after blowing away the current build of License server on Server 2016.

Maybe an easy question but why is there a License server conflict to begin with? Is there some sort of broadcast going on in the background where it looks for other License servers? The production server is configured to look at itself since it has the licenses but instead it complains about licenses on another server.
answered Sep 18, 2017 by itadmin (180 points)
248 questions
263 answers
106 comments
2,087 users