+1 vote

Visual Studio

The Visual Studio 2015 VSIP integration does not work with Surround SCM 2015.0 and earlier.

The Surround SCM VSIP Integration Provider plug-in is not available in Visual Studio 2015 after installing it with Surround SCM 2015.0 or earlier on a computer with multiple Visual Studio versions.

The following error is returned in Visual Studio when working with a project under Surround SCM source control:

‘An error occurred registering this project with source control.’

Cause

Surround SCM 2015.0 and earlier installers do not include the required Visual Studio 2015 VSIP integration package.

asked Nov 12, 2015 in Surround SCM by Nico

1 Answer

0 votes
Best answer

Manually install the Visual Studio Integration Extension and enable the plug-in.

Note: The SurroundSCMVSPackage.dll library must be installed in the Surround SCM application directory for the integration to work. If this library is not installed, contact Seapine support for help.

  1. Download the SSCMVSAdapter.vsix file .
  2. Double-click the file. The VSIX Installer opens.
  3. Select Microsoft Visual Studio 2015 as the product to install the extension to and click Install.
  4. Click Close when installation completes.
  5. Restart Visual Studio. The Surround SCM Integration Provider plug-in is installed and enabled.

See Surround SCM Visual Studio Integration for information about using and troubleshooting the integration.

answered Nov 12, 2015 by nico (8,200 points)
248 questions
262 answers
106 comments
2,047 users