+1 vote
I have installed both TestTraclPro and Surround SCM client (V2016.0.0) on my linux computer running OpenSUSE 11 SP3, but get errors when I try to run them.  v2014.1.0 of both clients ran fine on this conputer. although I did not see any items in the release notes about dropping support for OpenSUSE 11, I did notice that searching for Linux requirements to run these programs, it lists OpenSUSE 12.2.
asked May 19, 2016 in General by Paul Wolter
Thanks for the info.  Read through the knowledge base and several libraries showed up as not found. Installed the missing libraries and after several iterations, all libraries are found when performing the ldd function on the executable and the dynamic libraries.  When I run ttclient, I now get the following error:

ttclient symbol lookup error: /usr/lib/seapine/tt/libQt5XcbQpa.so.5  Undefined symbol:  XIQueryVersion

Could this be an issue with the version of the libQt5XcbQpa.so library that is installed versus what is expected?  I have libQt5XcbQpa.so.5.5.1 installed.

 

Thanks

1 Answer

+2 votes
Support for OpenSUSE 11.3 was officially dropped in TestTrack 2016.0.0 and Surround SCM 2016.0.0. With that said, the applications should still work on OpenSUSE 11.3. With 2016.0.0 some new library dependencies were introduced. Please refer to the following knowledge base article to determine what dependencies are missing on your machine: http://www.seapine.com/knowledgebase/index.php?View=entry&EntryID=276 . The KB article discusses 32 bit executables running on 64 bit Linux distributions but it also applies to 64 bit executables running on 64 bit Linux distributions.
answered May 19, 2016 by anonymous
Thanks for the info.  Read through the knowledge base and several libraries showed up as not found. Installed the missing libraries and after several iterations, all libraries are found when performing the ldd function on the executable and the dynamic libraries.  When I run ttclient, I now get the following error:

ttclient symbol lookup error: /usr/lib/seapine/tt/libQt5XcbQpa.so.5  Undefined symbol:  XIQueryVersion

Could this be an issue with the version of the libQt5XcbQpa.so library that is installed versus what is expected?  I have libQt5XcbQpa.so.5.5.1 installed.

 

Thanks
248 questions
263 answers
106 comments
2,072 users